Jump to content
pconkie

New frog code widget won't install

Recommended Posts

Can somebody take a look at my server to see if they get the same thing?

I have a forgcode widget called "forms advanced".  I've just tried to install it a couple of times.

The installation does not give an error but the widget does not install either!

Link to post
Share on other sites

Also., I was trying to install it because sometimes you get error messages in the staging environment that go away when it is installed.  Since I haven't been able to check if the error persists when installed could somebody please take a look at this and let me know if they spot the problem?

Frog.Model.api('dataviewer.gettable', {
  content_uuid: "BDA1BE902003E668FAF13F901358DF0BE4D3796C62C9C508",   //What is this? Do I need it?
  current_user_only: false,
  form_uuid: this.form_uuid,
  limit: 5,
  offset: 0,
  sort_dir: "DESC",
  sort_field: "date",
  filters: [{field_name: uuid, value: value}]
}).done(function(resp) {
  console.log(resp);
}.bind(this)).fail(function(e) {
  var error = JSON.parse(e.responseText);
  var error_msg = error.response.message + "<BR/>Failed to get timetable data"
  this.hideLoader();
  this.modal("There has been an error", error_msg, "pc-modal", null, false);
}.bind(this));  

The error message is 4000: missing module for table.

Thank you

Link to post
Share on other sites
3 hours ago, pconkie said:

Can somebody take a look at my server to see if they get the same thing?

I have a forgcode widget called "forms advanced".  I've just tried to install it a couple of times.

The installation does not give an error but the widget does not install either!

Its broke.... 😢

Link to post
Share on other sites
3 hours ago, Graham Quince said:

Hi @pconkie,

I'm also having issues with installing widgets and have reported it to the developers.  I think a fix has been made and is being checked currently.

Sorry about this

Graham

Thanks @Graham Quince.  Could somebody take a look at my api call then? Maybe @adamw will know what the error message means?

Link to post
Share on other sites
On 11/11/2020 at 10:51, pconkie said:

Also., I was trying to install it because sometimes you get error messages in the staging environment that go away when it is installed.  Since I haven't been able to check if the error persists when installed could somebody please take a look at this and let me know if they spot the problem?


Frog.Model.api('dataviewer.gettable', {
  content_uuid: "BDA1BE902003E668FAF13F901358DF0BE4D3796C62C9C508",   //What is this? Do I need it?
  current_user_only: false,
  form_uuid: this.form_uuid,
  limit: 5,
  offset: 0,
  sort_dir: "DESC",
  sort_field: "date",
  filters: [{field_name: uuid, value: value}]
}).done(function(resp) {
  console.log(resp);
}.bind(this)).fail(function(e) {
  var error = JSON.parse(e.responseText);
  var error_msg = error.response.message + "<BR/>Failed to get timetable data"
  this.hideLoader();
  this.modal("There has been an error", error_msg, "pc-modal", null, false);
}.bind(this));  

The error message is 4000: missing module for table.

Thank you

Ok I'm intrigued........  whats it for??  Another Conkie Special??

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...